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Delete BOMs

Delete BOMs lets you safely delete multiple bills of material from Inventory Control in a single process.

Sage 300 lets you delete individual bills of material using the Bills of Material screen, and it lets you
delete inactive BOMs using Delete Inactive Records. However, neither method provides the control and
efficiency of Delete BOMs.

Delete BOMs lets you:

e Select ranges of BOMs by item number, BOM number, unit of measure, start date, end date,
status, or date inactive. You can select ranges using up to seven fields — or you can import a list
of the BOMs that you want to delete.

e Specify additional selection criteria using BOM fields.
e Load the list of BOMs from the range that you specified.
o See the status of all BOMs in the list, as well as which ones are “In Use”.

o Even if BOM quantities are zero, BOMs can still appear in orders or historical data that has
yet to be purged.

o Ifa BOM is deleted when it is still referenced in other modules, the integrity checking program
will flag these references as errors, and some operations in Sage 300 may not behave as
expected. In addition, some reports will display incomplete or inaccurate data.

o Delete BOMs looks through all core Sage 300 tables and known third-party tables searching
for references to all BOMs matching your selection criteria, then displays all database tables
that reference those BOMs in the “In Use” column.

e Cherry-pick” BOMs for deletion that are “safe-to-delete”.

e Optionally Delete BOMs individually by selecting them from the loaded list of BOMs and pressing
the Delete key.

e Press a Process button to delete all selected BOMs in one step.
o View a log of all deletions after processing.

Note: You cannot delete a bill of material that is a component item (or subassembly) of
a multilevel BOM.

Important Disclaimer: Delete BOMs is driven by XML files that identify Sage 300 and third-party
products with the tables and columns of the products that contain inventory BOMs.

TaiRox does not guarantee that these XML files are accurate, complete or up-to-date, and that all
references will be detected by Delete BOM's search.

If other users are using Sage 300 when Delete BOMs is being run, the results of the search may be

out-of-date as displayed. TaiRox is not responsible for any damaged or lost data as a result of using
Delete BOMs. A Sage 300 Certified Consultant should be involved in any extensive deletion process
so that integrity checks and other tests can be performed after deletion.

Nevertheless: Sage 300 business objects are used to delete BOMs, so the resulting database will
have at least as much integrity as if a Sage 300 Ul was used to delete BOMs. If a BOM has
references undetected by Delete BOMSs, in many cases data can be repaired by simply adding the
BOM back to the database.

Delete BOMs creates a log of all BOMs that it deletes.

TaiRox Productivity Tools for Sage 300 1

© TaiRox Software Inc. All rights reserved.



Delete BOMs Running Delete BOMs

Running Delete BOMs

The Delete BOMs icon appears under TaiRox Productivity Tools > Inventory Control Tools on
the Sage 300 desktop and can be copied to other menu locations.

L]
Home

> Purchase Orders ()
SOX Check Approval Inventory Control Tools (Delete BOMs)
S0K Second Sight Licensed to: TAIROX SOFTWARE INC, TAIROX SOFTWARE INC
> TaiRox CRM and Cellections Dealer: TAIROX SOFTWARE INC
TaiRox Extended Processing o= TAIROX SOFTWARE INC
~ TaiRox Productivity Tools
Accounts Payable Tools
Accounts Receivable Tools ol
Ad e Services Tool Extended Inventory  Extended Locations Extended Vendor Extended Customer  Extended Location Extended
Ay (e S 12t lterns Details Details Details Manufacturers' ltems

General Ledger Tocls

Inventery Contrel Tools 0 :: E‘] ::
RAUE Comeanylioak Extended ltem Pricing  Extended Reorder Extended I/C Stock R’enrder Mail Merge Fix [tem \u;aluatlon
Order Entry Tools Quantities Segment Codes Errors
Payroll Tools
Purchase Order Tools ?Q v\\

> US Payroll Delete ltems Delete BOMs Kit Component Usage Remove ltems frem

> Visual Process Flows Inquiry Price Lists

v
SCISG For Help, press F1 Session Date: 2023-07-04 E A

The Delete BOMs screen (below) lets you select which BOMs you wish to delete by specifying a range of
item numbers, BOM numbers, units of measure, start dates, end dates, status, or date inactive. You can
use up to seven fields to specify ranges.

PTDEMO - Delete BOMs

File  Help

Bills of Material Range

Select Bills of Material By From To
fiNone)| v

{Mone) -

(Mone) -

(None) -

(Mone) -

(Mone) -

(Mone) -

=

Include | [B tem Number BOM Number | tem Description Description Fixed Cost

€ [ r
Select Al Select None
Frocess Close
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Selecting BOMs for deletion

Choose ranges of BOMs:

PTDEMO - Delete BOMs

File Help

Selecting BOMs for deletion

Bills of Material Range
Select Bills of Material By From To

ftem Number - | |" i

Date Inactive - [pvo207 | [m/01/2018

BE

(Mone) -

BOM Mumber

Unit of Measure

Start Date

End Date

Status

(None} -

Additional Criteria...

Load

e You can specify ranges of BOMs to restrict them by specifying a range of item numbers, BOM
numbers, units of measure, start dates, end dates, status, or date inactive. You can select ranges

using up to seven fields.

For instructions on importing a list of BOMs for deletion using the File > Import menu choice, see

Importing a List of BOMs for Deletion.

Choose additional criteria:

Addtional Criteria Load
i
Q Set Criteria - Items EI@

Field Status -
Citena  =INACHYE |

Or

e Click Additional Criteria to further restrict the BOMs retrieved for deletion. In this case, we are

only going to load inactive BOMs.
e Click OK to save.

Load the list of selected BOMs and choose which ones to delete:

e Click the Load button to display the selected list of BOMs.

[ Addttional Criteria... ]

Incude | (B tem Number BOM Number

Mo F3HUNTS-2500)T 2
Mo F3HUNTS-2500)T 3

tem Description

Hurts 2500 Series Filing Cabingt
Hunts 2500 Series Filing Cabinet

De=~.ptian

Fixed Cost Build |

100.00

o Go back and adjust the ranges or additional criteria if necessary.

e Scroll Right or Expand the form to see additional columns of information.

Start Date | End Date Status Date Inactive | In Use

Inactive 101042018 ftem Mumber in use in table ICBOMD

Inactive 10.10/2018 fterm Mumber in use in table ICBOMD

In this case, you can see that both BOMs are inactive and appear in table ICBOMD.
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Importing a List of BOMs for Deletion

Choose File > Import from the Delete BOMs menu.

SAMLTD - Delete BOMs

Customize...

Import...

Close

Select the list of BOMs that you want to process.

r N
% Open ==
o~
& ») [ 1 » Computer » Local Disk (C) » Sage300 » XLELA » Documentation » [ 42 ][ Search Documentation 3

Organize + New folder =~ A @
| TXE6A ~  Name ° Date modified Type Size |+
| TH6TA
PTA | ENG 11/18/202012:45 .. File folder

) P ] BillsOfMaterial xlsx 11/12/2020 1:24 PM Microsoft Excel W... 9KB

: UQ6§A ] Customers.xisx 11/12/2020 1:24 PM Microsoft Excel 10KB

: u%ﬁag (] Employees.lsx 11/12/20201:24 PM Microsoft Excel 10KE L
) " ] rems.lsx 11/12/2020 1:24 PM  Microsoft Excel 10KE

) iean i ] ItemSubstitutes.xlsc 11/12/20201:24 PM Microsoft Excel 10KB

. — &) Ordersxisx 11/18/20201:00 PM  Microsoft Excel W... 9KB

The program will import the list and load all relevant BOMs into the grid — setting all BOMs to
“Include” — and display a message stating the number of BOMs that were successfully loaded,
and the number of BOMs that could not be imported.

Include | [& tem Number BOM MNumber | ltem Description Description

Yes AZ(IMAGE-1500)G 1 Image 1500 Series Desk Accessories

Yes AZ(KINGS-5000)B 1 Kings 5000 Series Desk Accessores

Yes AZ(QUEEN-STAR)D 1 Queen Star Series Desk Accessony

o Message M

Message
Description: 3 Bills of Materal imported from 'C:\Sage300"XL614A -
“\Documentation'BillsCf Material xlsx’".

The program will reject BOMs that cannot be processed, and will not import them.

For example, you cannot delete a bill of material that is a component item (or subassembly) of a
multilevel BOM.

All BOMs that can be deleted will be loaded into the grid at the botton of the screen. You can then
confirm which BOMs you want to delete.

Choosing Items from the Grid for Processing

o Use the Select All and Select None buttons below the grid to set all BOMs to Yes for Include or
No to exclude.
[ SelectAl ][ SelectNome |
e Double-click in the Include column to “cherry-pick” from the BOMs:
[ Addtional Criteria... | Load
Include | [H tem Number BOM Number | ttem Description Description Ficed Cost
N F3(HUNTS-2500)T | 2 Hunts 2500 Series Fiing Cabinet 50.00
No FIHUNTS-25000T 3 Hurts 2500 Series Fiing Cabinet 100.00
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Choosing Items from the Grid for Processing

e Click the Item Number column heading to drill down on the selected BOM to confirm the details:

Include | [B tem Mumber h_. BCOM Mumber | kem Description Description

Yes

2 Hurts 2500 Series Filing Cabinat
Hurts 2500 Series Filing Cabinat

You can also delete a BOM by selecting it and pressing the Delete key:

e You can also delete a BOM by selecting the row in the Load list and pressing the Delete key.
When the delete key is pressed you will be prompted to confirm the deletion of that BOM.

r

Delete BOMs

=)

Are you sure you want to delete ltem Mumber F3(HUNTS-2500)T BOM Number 27

L

Click the Process button to delete the included BOMSs:

The program asks you to confirm your choices.

e Click Yes to continue.

Delete BOMs

==)

Are you sure you want to delete the selected bills of material?

Note: There can also be data-integrity errors that prevent some deletions, in which case an error
message will appear.

Click the Log button to confirm which BOMs were deleted:

In this case, deletion failed because the selected BOM was a subassembly of a multilevel BOM.

10/10/2018
10/10/2018
10/10/2018
10/10/2018
10/10/2018
10/10/2018
10/10/2018
10/10/2018
10/10/2018

e e e

component of

10/10/2018 1:
10/10/2018 1:
10/10/2018 1:

:40:03
:40:03
:40:03
:40:03
:40:03
:40:03
:40:03
:40:03
:40:03
10/10/2018 1:

40:03

'item:

40:03
40:03
40:03

PM Delete BOMs started.

PM

PM Performed by user: ADMIN

PM

PM Bills of Material Range

PM Item Number From [F3 (HUNTS-2500)T] To [ZZ22227ZZ7Z7Z7272727222222222277]
PM Date Inactive From [1/1/2017] To [1/1/2019]

PM

PM Deleting Item Number F3 (HUNTS-2500)T BOM Number 2...

PM Cannot delete 'item: F3HUNTS2500T, bom: 2' because it is a
A2IMAGE1500G, bom: 2'.

PM

PM Delete BOMs complete.

PM

The Log lists:

e The user and the range settings for the procedure.

e Each item that was deleted.

e Reason why deletion failed.
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Delete BOMs XML Control File — Applications.xml
The following XML file is used to control application checking for item references.

<?xml version="1.0" encoding="UTF-8"?>
<Applications xmins:xsd="http://www.w3.0rg/2001/XMLSchema"
xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-instance">
<Application>
<Selector>IC</Selector>
<Name>Inventory Control</Name>
<Check>true</Check>
</Application>
<Application>
<Selector>OE</Selector>
<Name>Order Entry</Name>
<Check>true</Check>
</Application
></Applications>

TaiRox Productivity Tools for Sage 300

© TaiRox Software Inc. All rights reserved.


file:///C:/Users/morgant/TaiRox%20Documents/-%20USER%20GUIDES%20-%20doc/Productivity%20Tools%20User%20Guides/IC%20Tools/%3cApplications%20xmlns:xsd=%22http:/www.w3.org/2001/XMLSchema%22%20xmlns:xsi=%22http:/www.w3.org/2001/XMLSchema-instance%22%3e
file:///C:/Users/morgant/TaiRox%20Documents/-%20USER%20GUIDES%20-%20doc/Productivity%20Tools%20User%20Guides/IC%20Tools/%3cApplications%20xmlns:xsd=%22http:/www.w3.org/2001/XMLSchema%22%20xmlns:xsi=%22http:/www.w3.org/2001/XMLSchema-instance%22%3e
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File Formats for Imported BOM Lists

Delete BOMs lets you select BOMs using an imported list.
Import files are Excel files.

You can find examples of import lists in directory “...\Sage300\XL61A\Documentation”.

BOM Lists

The Excel Spreadsheet BOM list has two columns, with “ITEMNO” and BOMNO as the column headings
in the first row.

A B
1 [ITEMNO BOMMNO
2 A2(IMAGE-1500)G 1
3 AZ2(KINGS-3000)B 1
4 A2({QUEEN-STAR)O 1
Notes:

e |tem numbers can be formatted or unformatted.

o All other columns are ignored. This means that you can add item descriptions and notes to your
spreadsheet without affecting the file import.
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