
Ship Orders Running Ship Orders 

TaiRox Productivity Tools for Sage 300  1 

© TaiRox Software Inc. All rights reserved.  

Ship Orders 

Businesses often have orders that aren’t fulfilled because items are backordered. When the items arrive, 

the orders need to be processed – but first they must be identified, then called up individually in the Order 
Entry module, and then shipped. It’s a very time-consuming process. 

Ship Orders eliminates the time-consuming steps involved in shipping Order Entry orders from Sage 300 
Order Entry. It even lets you invoice orders in the same process, so all your shipping and invoicing can be 
processed in one day-end task. 

Ship Orders lets you:  

• Select orders by specifying ranges of order numbers, order dates, customer numbers, expected 
ship dates, PO numbers, ship-to locations, territories, tracking numbers, and optional fields -- or 
import a list of orders that require processing. 

Range selection uses the same mechanisms used by core modules when printing reports.  

• Filter orders by location. 

• Specify additional criteria using other order fields. 

• Select orders based on one or more specific items. If you specify items, all orders that contain 
one or more items from the item set will be selected. 

• Only ship orders that have been prepaid. 

• Ship orders that meet standard shipping scenarios: 

o Only Orders That Can Be Completely Shipped 
o Only Back Ordered Quantities in Selected Orders 
o Only Committed Quantities in Selected Orders 
o All Selected Orders, Allowing Partial Shipments 

• Choose to invoice shipped items at the same time. 

• Specify different shipment and invoice dates. This is especially useful if you are processing a 
large number of orders, where the accounting process may lag behind order processing.  

• Enter the name and password of a user with the rights to override credit limits if shipping orders 
would cause a customer to go beyond their credit limit and you wish the limit to be overridden. 

• After selection, review the list of unshipped orders and cherry-pick ones for shipment. 

• Click the Process button to complete the operation in one step.  

• Quickly print a number of order-related forms, without navigating to another window. 

Running Ship Orders 

The Ship Orders icon appears under TaiRox Productivity Tools > Order Entry Tools on the Sage 

300 desktop and can be copied to other menu locations. 
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The Ship Orders screen appears below: 

 

Selecting and processing orders for shipping 

Specify ranges of orders for selection: 

You can select orders by providing order ranges and specifying additional criteria – or you can import 

a list of the orders that you need to process. 

You can specify up to seven order fields to use for primary order selection – such as the order 

number, order date, customer number, expected order date and optional fields (if added). The screen 
below shows a number of optional fields. 

 

• The dropdown field list shown above includes a number of standard order fields and optional 
fields, and you can add or remove fields from the dropdown list. 

Import a list of orders for processing 

You can import a list of the orders that you need to process instead of providing order ranges and 
specifying additional criteria. 
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Important: If you importing a list of orders, choose all other criteria for shipping orders before 
importing the order list. 

For example, select a location, select the “All Items” or “Specific Items”, select the “Ship” options, 

specify the shipment and invoice dates and the credit approver, and then import the order list. 

For details on specifying and loading ranges of orders, see Import Specify ranges of orders for 
updating. 

To import a list of orders for updating: 

• Choose File > Import from the Ship Orders menu. 

 

• Select the list of orders that you want to process. 

 

• The program will import the list and load all relevant orders into the grid – setting all orders to 
“Include” – and display a message stating the number of orders that were successfully loaded, 
and the number of orders that could not be imported. 

 

The program will reject orders that cannot be processed. 

For example 

o If you specified a list of items for shipping orders, the program will reject orders that do not 
include the items you specified. 

o The program will reject completed orders. 

• You can double-click the “Include” column to remove orders from the update. 
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Use the “Field Settings” button to customize the list of fields for selecting orders: 

Click the Field Settings button to change the fields that appear in the “Select Orders By” dropdown 

field list.  

 

• The list of fields on the right are the fields that will appear in the Select Orders By dropdown.  

• To add a field to the dropdown list, select it in the list on the left, and click the Include button. 

Note regarding order dates:  

• If you choose a range of Order Dates, the default “To” date is set by a screen accessed through 
the Ship Orders > File > Settings menu choice: 

 

You can override the default in the Range fields. 

Specify one or all locations: 

• The last Select Orders By drop-down lets you filter by location.  

This means that orders are selected if any detail lines match the specific location. 

 

Choose additional criteria if necessary: 

To select orders from a field that is NOT available on the Field Settings form, use Additional Criteria. 

 

• Click the Additional Criteria button to further restrict the orders retrieved for shipping.  
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• Select a field in the dropdown and click the Add button. 

• Double-click the Criteria field to enter a relationship and value. 

• Click OK to save. 

Choose all items or specific items: 

• The form includes radio buttons for selecting "All Items" or "Specific Items".  

If you choose Specific Items, the Drill Down button will appear next to the radio buttons. Click the 

button to open a window for specifying items.  

The list will be remembered from the previous time you used it to load orders. 

To insert items: 

o Use the Insert key to add more items to the list. 

o Use the Delete key to remove items. 
o The list will be remembered from the previous time you used it to update orders.  
o Click the Reset Defaults button to delete all items from the list. 

 

To import a list of items: 

o Click the Import button at the bottom of the popup form and select the spreadsheet containing 

the item list. 
− The imported list will replace the current list of items. 

o Use the Insert key to add more rows to the list. 
o Use the Delete key to remove items from the imported list. 

Import format: 

You can find a sample import file in directory \Sage300\XL61A\Documentation. 

The Excel Spreadsheet for an item list (Items.xlsx) is a single column with “ITEMNO” as the 
column heading in the first row.  

 

• On the pop-up Item form, choose to ship all items on order or only the listed items. 

o If you choose “Ship All Items on Order”, all the items for the selected order will be shipped.  
o If you choose “Ship Only Listed Items on Order”, all the items that you enter in the list will be 

shipped on an order, and any other items that appear on the order will not be shipped.  
o Any miscellaneous charges that are entered on an order will also appear on the shipment. 
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Choose whether to Only Ship Orders That Have Been Prepaid: 

Ship Orders lets only ship orders if they have an associated prepayment. 

 

Notes:  

• If you choose to only ship orders with prepayments, Ship Orders will check A/R Receipts for a 
prepayment. 

• Ship Orders does not check Order Entry Prepayments, so it supports integrations such as 
WebSyncERP that create prepayment batches without using the Order Entry prepayment 
mechanism. 

Choose a Shipment Scenario: 

Ship Orders provides four options to control shipments: 

 

Notes:  

• Option 1, “Only Orders That Can Be Completely Shipped”, is a processing option. It does not filter 
the list of orders that appear in the grid based on inventory levels, but the program will not 
partially ship an order: it will only ship an order if the whole order can be shipped. The purpose is 
to save on shipping costs. 

• The A/R Customer Invoicing option "Allow Partial Shipments" is respected only for the "All 
Selected Orders" option.  

This option will also ship orders that are comprised only of miscellaneous charges.  

• For the first 3 options, miscellaneous charges will be included in a shipment if and only if an item 
is shipped. 

• When the “Allow Negative Inventory Levels” option is used in Sage 300 Inventory Control, the 
program will create shipments and complete order lines even if inventory levels are negative. 

Choose the Shipment and Invoice dates: 

The Shipment and invoice dates default to today’s date. You can change them if necessary. 

 

Supply a credit approver to override credit limits: 

If the person shipping the orders does not have sufficient permissions to override credit limits, you 

can add the ID and password of a user with full rights. 

Note:  Do this only if shipping orders would cause a customer to go beyond their credit limit and you 

want the limit to be overridden. 
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Load the list of selected orders and choose which ones to ship: 

If you are importing a list of orders for processing, import the list now instead of clicking Load. 

 

• Click the Load button to display the selected list of orders. 

When the Load button is pressed, the active orders that match the selection criteria will be 

displayed, allowing you to drill down on orders to confirm your selections. 

Important Note: Orders are selected for inclusion based on the moment that the Load button 

is pressed. The order may be changed before processing is completed. Make sure that you 
consult the log to see the actual processing that has taken place. 

o You can adjust the ranges or additional criteria if necessary, then click Load again. 

• Click the Select All and Select None buttons at the bottom of the screen to include all or none of 
the orders loaded in the grid. 

 

• Double-click in the Include column to “cherry-pick” orders: 

 

• Click the Order Number column heading to drill down to the selected order: 

 

• Click the Invoice All button to create invoices for the orders that you are shipping: 

 

• Double-click in the Invoice column to selectively invoice orders. 
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Click the Process button to ship and/or invoice the included orders: 

The program asks you to confirm your choices. Click Yes to continue. 

 

Note:  There may be data-integrity errors that prevent some shipments, in which case an error 
message will appear.  

Error messages will list any orders in a list that could not be updated, along with the reasons. 

Click the Log button to confirm which orders were shipped and 
invoiced: 

7/11/2020 10:24:13 AM Ship Orders started. 

7/11/2020 10:24:13 AM  

7/11/2020 10:24:13 AM Performed by user: ADMIN 

7/11/2020 10:24:13 AM  

7/11/2020 10:24:13 AM Order Range 

7/11/2020 10:24:13 AM     Order Date From [2/1/2019] To [5/1/2020] 

7/11/2020 10:24:13 AM  

7/11/2020 10:24:13 AM Shipment Date: 1/10/2020 

7/11/2020 10:24:13 AM Invoice Date: 1/10/2020 

7/11/2020 10:24:13 AM  

7/11/2020 10:24:13 AM All Items 

7/11/2020 10:24:13 AM Ship: All Selected Orders, Allowing Partial Shipments 

7/11/2020 10:24:13 AM  

7/11/2020 10:24:13 AM Shipping Order Number ORD000000000066... 

7/11/2020 10:24:15 AM     Order Number ORD000000000066 shipped. Shipment number 

SH00000000000000000064, Invoice Number IN0000000000063. 

7/11/2020 10:24:15 AM Shipping Order Number ORD000000000069... 

7/11/2020 10:24:15 AM     Order Number ORD000000000069 shipped. Shipment number 

SH00000000000000000065, Invoice Number IN0000000000064. 

7/11/2020 10:24:15 AM  

7/11/2020 10:24:15 AM Ship Orders complete. 

7/11/2020 10:24:15 AM 

================================================================================ 

The Log lists: 

• The user, the type of orders selected, and the full range settings.  

• Each order that was shipped and optionally invoiced, along with the shipment and invoice 
numbers.  



Ship Orders Print Order Entry forms 

TaiRox Productivity Tools for Sage 300  9 

© TaiRox Software Inc. All rights reserved.  

Print Order Entry forms 

 

• Click the O/E Forms button to pop up a print window. You can print order information, picking 
slips and invoices using the Sage 300 printing functions. 
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File Formats for Imported Order and Item Lists 

Ship Orders lets you ship orders based on an imported order list and an imported item list. 

Import files – orders and items – are Excel files.  

You can find examples of import lists in directory “…\Sage300\XL61A\Documentation”. 

Order List 

Instead of specifying a range of orders and clicking the Load button, you can directly import a list of 

orders. 

The Excel Spreadsheet order list is a single column with “ORDNUMBER” as the column heading in the 

first row.  

 

• All other columns are ignored. This means that you can add item descriptions and notes to your 
spreadsheet without affecting the file import. 

Item Lists 

The Excel Spreadsheet item list is a single column with “ITEMNO” as the column heading in the first row.  

 

Notes: 

• Item numbers can be formatted or unformatted. 

• All other columns are ignored. This means that you can add item descriptions and notes to your 
spreadsheet without affecting the file import. 
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