Update Shipments Selecting and updating shipments

Update Shipments

Update Shipments eliminates the time-consuming steps involved in changing details for dozens or
hundreds of shipments orders in the Sage 300 Order Entry module.

The Update Shipments screen lets you select the update action that you want to perform, the items you
want to update, and then specify the ranges of shipments that need to be updated — or import a list of the
shipments that you need to process.

You can view and cherry-pick the list of shipments, and then click the Process button to complete the
operation in a single step. You can display a log of all changes when processing is complete.
Update Shipments lets you change selected shipments:

o When a price list has changed for an item or list of items or all items.

¢ When a ship date has changed for an item or list of items or all items.

The Update Shipments icon appears under TaiRox Productivity Tools > Order Entry Tools on the
Sage 300 desktop and can be copied to other menu locations.
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The Update Shipments screen appears below:

The program lets you update item prices or item shipment dates. You can select shipments by
shipment number, shipment date, customer number, or any optional fields used in shipments.
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Update Shipments Selecting and updating shipments

Selecting and updating shipments

Choose what to update:

Update Shipment
Update ftem Prices |L]

I

Update ttem Shipmert Date

Note: Once shipments have been invoiced, the price can no longer change.

Update Item Prices

e Once shipments have been invoiced, the price cannot be changed.

Update Shipment

w  Specific tem -

ttem Number | | Q | |
Price List | 1Q | |

e Select “Update ltem Prices”, then:
o Choose a specific item, list of items, or all items.

Click the Drill-Down button to specify a list of items or to import an item list. See the section
below on choosing items.

-
o Select the Price List for updating pricing.
Update Item Shipment Date

|Update Shipment
pdate tem Shipment Date = Specffic tem -

ltem Number | | Q |
Shipmenrt Date

Update Shipment Header Shipment Date Also

e Select “Update ltem Shipment Date”, then:
o Choose a specific item, list of items, or all items.
Click the Drill-Down button to specify a list of items or to import an item list. See the section
below on choosing items.
-

o Specify the new Shipment Date for the items.
o Click the Update Shipment Header Shipment Date Also to change the shipment date for the
entire order at the same time.
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Choosing a single item, list of items, or all items:

e If you choose a list of items, the list will be remembered from the previous time you used it to load

orders.
e To create/edit or import an item list. click on the Drill Down icon on the right side of the “List of
Items” choice.
Update Shipment
Update tem Shipmert Date *  List Of kems - f_,

% PTDEMO - Update Shipments

Q, tem Number tem Description
N [ Al-310/0 Halogen Deske Light

To insert items:

o Use the Insert key to add more items to the list.

o Use the Delete key to remove items.

o The list will be remembered from the previous time you used it to update orders.
o Click the Reset Defaults button to delete all items from the list.

To import a list of items:

o Click the Import button at the bottom of the popup item list form and select the spreadsheet
containing the item list.
e The imported list will replace the current list of items.

o Use the Insert key to add more rows to the list.
o Use the Delete key to remove items from the imported list.
o Click the Reset Defaults button to delete all items from the list.

Import format:
You can find sample import files in directory \Sage300\XL61A\Documentation.

Note: The Excel Spreadsheet for an item list (Items.xIsx) is a single column with “ITEMNO” as
the column heading in the first row.

A
1 ITEMNO
2 |A11030
3 |A11050

Specify ranges of shipments for selection:

You can select orders by providing order ranges and specifying additional criteria — or you can import
a list of the shipments that you need to process.

For details on importing a list of orders, see Import a list of shipments for processing.
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You can specify up to seven fields to use for shipment selection — including the shipment number,
shipment date, customer number, and any optional fields.

Shipment Range
Select Shipments By From To

(None) |:]
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Shipment Number
Shipment Date
Customer Number
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roved
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Note
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Temporary Customer [ Field Settings... ] [ Load
UP5 Zone

F‘Elﬁa's:rl;anty ert Date | Shipment Description | Customer Mum... | Bill-To Name

Wayhil

¢ You can add or remove fields from the dropdown list using the Field Settings button.

Use the “Field Settings” button to customize the list of fields for selecting shipments:

Click the Field Settings button to change the fields that appear in the “Select Shipments By”
dropdown list.

Select Shipments By From To
Shipment Number - |5"‘ 7 ‘ Q | b
# PTDEMG - Update Shipments Field Settings [
[Sip To Locaion Coce
Shipment Tracking Number — Customer Number
Customer Accourt Set s Pxude Order Number
Salesperson 2 Order Date
Salesperson 3 Expected Ship Date
Salesperson 4 L Purchase Order Number
Salesperson 5 3 Temitory
All Salespeople Salesperson 1
Picking Slip Printed Customer Credit Waming 4 [ Field Settings. . ] [ Load
Ship-Via Code Prefemed Customer
Default Location Code UPS Zone tion | Customer Num Bill-To Name
Tax Group | & i
Entered By
ACH
Approved
Courier
Maximum Order Amount o
L

e The list of fields on the right are the fields that will appear in the Select Shipments By dropdown.

e To add a field to the dropdown list, select it in the list on the left, and click the Include button.

Note regarding shipment dates:

e If you choose a range of Shipment Dates, the default “To” date is set by a screen accessed
through the Update Shipments > File > Settings menu choice:

% PTDEMO - Update Shipments Settings ==
Mumber of Months Prior to Session Date to Update Shipments E‘

You can override the default in the Range fields.

Choose additional criteria if necessary:

To select shipments with a field that is NOT available on the Field Settings form, use Additional
Criteria.
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Selecting and updating shipments

i e

Q Set Criteria - Shipments

Calumn

Tenitory
Field Teritory -
Criteria  E=AK e l

Or

Click the Additional Criteria button to further restrict the shipments retrieved for updating.
Select a field in the dropdown and click the Add button.

Double-click the Criteria field to enter a relationship and value.

Click OK to save.

Load the list of selected shipments and choose which ones to update:

Additional Citeria... [ Field Settings..._g | Load ]
Incude | (B Shipment Number Bil-To Name Cumen...
Yes . The Courtyard UsD
Yes SHO0000000000000000065  1/10/2020 1200 Mr. Ronald Black  1USD
Yes SHOCOO0000000000000070  1/10/2020 1240 The Courtyard usD
4 i 3

[ Selectal || SelectNome | 3Shipments selected.
[ — | —re—

Click the Load button to display the selected list of shipments.

When the Load button is pressed, the active shipments that match the selection criteria will be
displayed, allowing you to drill down on shipments to confirm your selections.

Important Note: Shipments are selected for inclusion based on the moment that the Load
button is pressed. The shipment may be changed before processing is completed. Make sure
that you consult the log to see the actual processing that takes place.

o You can adjust the ranges or additional criteria if necessary, then click Load again.

Click the Select All and Select None buttons at the bottom of the screen to include all or none of
the shipments loaded in the grid.

[ Selectal ][  SelectNone |

Double-click in the Include column to “cherry-pick” shipments:

Include | [B Shipment Mumber Shipment Date | Shipment Description | Customer Num... | Bill-To Name Curren...

1/10/2020 1240 The Courtyard USD

oo 11200 | r Ronald Biack

fes k SHO00000D00D000000007D  1/10/2020 1240 The Courtyard UsSD

Click the Shipment Number column heading to drill down to the selected shipment:

[H Shipment Number

|_SHODDDDDODOODDDDD0OSS |

SHODO00D00000000000070
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Import a list of shipments for processing

you can import a list of the shipments that you need to process — or you can select shipments by
providing shipment ranges and specifying additional criteria.

Note that you must specify what you are updating in the “Update Shipment” section at the top of the
form before you import the shipment list.

For details on specifying and loading ranges of shipments, see Specify ranges of shipments for
selection.

To import a list of shipments for updating:

e Choose File > Import from the Update Shipments menu.

i SAMLTD - Update Shipments
File

Customize...
e v Al tems -
Import...

Llose . 01/10/2020

e Select the list of orders that you want to process.

% Open
QQ ‘ » Computer » Local Disk (C:) » Sage300 » XL6LA » Documentation »
Organize *  New folder
| TXG6A “ Mame ’ Dste modified Type Size |2
. TXBIA
ENG 11/18/2020 12:45 ... File folder
EZ:;’: \z‘_] BillsOfMaterial xlsx 11/12/2020 1:24 PM  Microsoft Excel W... 9KB
] Customers.xlsx 11/12/2020 1:24 PM Microsoft Excel W... 10 KB
b UGETA () Employees.xisx 11/12/2020 1:24 PM  Microsoft Bxcel W... 10 KB L
UTTsA \zl_l Trems.xdsx 11/12/2020 1:24 PM  Microsoft Excel W... 10 KB 1
uTrEC — \zﬂ ITtemSubstitutes.xlsx 11/12/2020 1:24 PM Microsoft Excel W... 10KE
. H?(EFA L (] Ordersxisx 11/18/2020 1:00 PM  Microsoft Excel W... 9KB

o The program will import the list and load all relevant shipments into the grid — setting all
shipments to “Include” — and display a message stating the number of shipments that were
successfully loaded, and the number of shipments that could not be imported.

[H Shipment Mumber Shipment Date | Shipment Description | Customer Mum...
Yes E
Message
Yes o <
Yes Message
e Description; 30 Shipments imported from T \Sage300VXLET1A -
Yes “Documentation*.Shipments xls<. 14 Shipments could not be imported. Please
Yes see the Update Shipments User Guide for more details.
¥i
- Source: 15:10:15 -
Yes

The program will reject shipments that cannot be processed.
For example

o If you specified a list of items for updating shipments, the program will reject shipments that
do not include the items you specified.
o The program will reject completed shipments.

e You can double-click the “Include” column to remove shipments from the update.

Click the Process button to update the included shipments:

The program asks you to confirm your choices. Click Yes to continue.

TaiRox Productivity Tools for Sage 300 6

© TaiRox Software Inc. All rights reserved.



Update Shipments

Selecting and updating shipments

Update Shipments

Are you sure you want to update the selected shipments?

ves || No

Important Notes:

e Once shipments have been invoiced, the price can no longer change.

o There may be data-integrity errors that prevent some updates, in which case an error window will
appear.

Click the Log button to confirm which orders were processed:

7/16/2020 3:11:55 PM Update Shipments started.

7/16/2020 3:11:55 PM

7/16/2020 3:11:55 PM Performed by user: ADMIN

7/16/2020 3:11:55 PM

7/16/2020 3:11:55 PM Update Item Shipment Date

7/16/2020 3:11:55 PM All Items

7/16/2020 3:11:55 PM All Items

7/16/2020 3:11:55 PM Shipment Date [1/10/2020]

7/16/2020 3:11:55 PM Update Shipment Header Shipment Date Also [Yes]
7/16/2020 3:11:55 PM

7/16/2020 3:11:55 PM Shipment Range

7/16/2020 3:11:55 PM Customer Number From [1200] To [1240]
7/16/2020 3:11:55 PM

7/16/2020 3:11:55 PM Updating expected ship dates for Shipment Number SH00000000000000066...
7/16/2020 3:11:55 PM Shipment Number SHO00000000000000066 updated.
7/16/2020 3:11:55 PM Updating expected ship dates for Shipment Number SH00000000000000070...
7/16/2020 3:11:55 PM Shipment Number SHO00000000000000070 updated.
7/16/2020 3:11:55 PM

7/16/2020 3:11:55 PM Update Shipments complete.

7/16/2020 3:11:55 PM

The Log lists:

e The user, the type of update performed, and the full range settings.

e Each shipment that was processed.
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File Formats for Imported Shipment and Item Lists

Update Shipments lets you change shipments based on an imported shipment list and an imported item
list.

Import files — shipments and items — are Excel files.

You can find examples of import lists in directory “...\Sage300\XL61A\Documentation”.

Shipment List

Instead of specifying a range of shipments and clicking the Load button, you can directly import a list of
shipments.

The Excel Spreadsheet shipment list is a single column with “SHINUMBER” as the column heading in the
first row.

A
1 SHINUMBER
2 | SHOO0O00000000000000063

o All other columns are ignored. This means that you can add item descriptions and notes to your
spreadsheet without affecting the file import.

Item Lists

The Excel Spreadsheet item list is a single column with “ITEMNO” as the column heading in the first row.

A
1 ITEMNO
2 |A11030
3 |A11050

Notes:
e Item numbers can be formatted or unformatted.

e All other columns are ignored. This means that you can add item descriptions and notes to your
spreadsheet without affecting the file import.
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