Complete Orders Running Complete Orders

Complete Orders

Businesses frequently have incomplete orders because items are out-of-stock or discontinued and will
never be shipped to a customer. As a result, orders remain open, and item quantities are unreliable.

Complete Orders simplifies the job of completing orders by finding incomplete ones, eliminating
discontinued items, zeroing the quantity outstanding and quantity committed values for each incomplete
line item, and then setting the order status to “Complete.”
Complete Orders lets you:

e Select incomplete orders based on items and miscellaneous charges on orders.

o You can choose to complete all items and miscellaneous charges within a range of orders,
complete a specific line item or miscellaneous charge, or complete all items specified by a list
that you import from an Excel spreadsheet file or enter on the Complete Orders form.

e Select ranges of incomplete orders, then load them into a grid to further “cherry-pick” ones for
completion — or import a list of the orders that you need to complete.

Complete Orders selects Order Entry orders with the same mechanism used by core Sage
modules when printing reports.

e Check order details while finalizing the completion list.
e Press a Process button to complete the operation for all selected orders in one step.
e Optionally delete completed orders.

e View a log of all changes after processing.

Running Complete Orders

The Complete Orders icon appears under TaiRox Productivity Tools > Order Entry Tools on the
Sage 300 desktop and can be copied to other menu locations.

> Taiox CRM and Collections ~
« TaiRox Productivity Tools Order Entry Tools
Accounts Payable Tools Licensed to: Don Thomson, TAIROX SOFTWARE INC
Accounts Receivable Tools Dealer: TAIROX SOFTWARE INC
Administrative Services Tools c TAIROX SOFTWARE INC
General Ledger Tools
S B S S B B B B
Multi-Company Tools E
Fepr Extended Order Entry Extended Shipment Extended O/E Invoice Extended CR/DR Note  Ship Orders Invoice Shipments  Update Orders ~ Update Shipments  Delete Orders
1 der Entry Tools | Entry Entry Entry
Payroll Teals. 1
Purchase Order Tools D 0 r‘ = E
> US Payroll = = o
o Delete Quotes Complete Orders | Create O/E Credit  Extended Ship-Via  Sales History Inquiry ~ Shipment Picking  Email Packing Slips  Customer Backorders
> Visual Process Flows Notes Codes Slips
v
Sage | ForHelp, pressF1 Session Date: 2023-09-07

The Complete Orders screen (below) lets you select which Orders you wish to complete by specifying
items, line type (items or miscellaneous charges), and various ranges of orders.
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Complete Orders Selecting orders for completion

PTDEMO - Complete Orders

File  Help

Complete Orders

-

Order Range
Select Orders By From To
(None) -

(Mone) -

(None) -

(Mone) -

{Mone) -

(Mone) -

{Mone) -

[ Field Seftings... | | Load ]

[& Order Number Order Date | Order Description Customer Mum... | Bil-To Name

4| m F

Select Al Select None

Selecting orders for completion

Choose items/miscellaneous charges:

Complete Orders
Complete all kem and Miscellaneous Charge Lines |L]

Complete a Specific tem Line
Complete a Specific Miscelaneous Charge Line
Complete a List of tems

Complete Orders displays the choice from the last time that you used the program — including the line
item number or miscellaneous charge code or the item list that you specified previously.

Complete all Item and Miscellaneous Charge Lines

e Choose this option to complete all items and miscellaneous charges in the range of orders you
specify. You can exclude orders from the range after you click the Load button.

Complete a Specific Item Line or a Specific Miscellaneous Charge Line

e These choices let you complete lines for a specific item or miscellaneous charge in all orders in
the range you specify. You can exclude orders from the range after you click the Load button.

Complete a List of Items
e This choice lets you create or import a list of items that you want to complete.

o Click the Drill Down icon on the right side of the dropdown field to create/import/edit the item list.
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Complete Orders Selecting orders for completion

The program displays a popup form that lets you add items to the list or import a list of items from
a spreadsheet.

Complete Orders

Complete a List of ftems v \
% PTDEMO - Complete Orders

Oy

Sel Q, kem Number ltem Description

A1-401/0 Desk Calendar Pad

To insert items:

o Use the Insert key to add more items to the list.

o Use the Delete key to remove items.

o The list will be remembered from the previous time you used it to load orders for completion.
o Click the Reset Defaults button to delete all items from the list.

To import a list:

o Click the Import button at the bottom of the popup form and select the spreadsheet containing
the item list.
— The imported list will replace the current list of items.

o Use the Insert key to add more items to the list.

o Use the Delete key to remove items from the imported list.

Note: The Excel Spreadsheet item list is a single column with “ITEMNO” as the column heading
in the first row.
i\
1 ITEMNO
2 Al1030
3 All1050

o Item numbers can be formatted or unformatted.
o All other columns are ignored. This means that you can add item descriptions and notes to
your spreadsheet without affecting the file import.

Choose the range of orders that you want to complete:

Order Range
Select Orders By From To
Order Number |L] | . i {

(Mone
— Number

Order Date

Customer Number
Order Type

Ship-To Location Code
Customer Group Code
Customer Account Set
Salesperson 1
Expected Ship Date
On Hold

ip?;;mved Field Settings... ] [
Courier

Customer Credit Waming
Maximum Order Amount
UPS Zone

Order Description Customer Num... | Bill-To Name

e You can select orders by specifying a range of values for up to seven order and optional fields —
such as a range of order dates, order numbers, customer numbers, or optional field values. The
screen above shows a list of order fields, including six optional fields.

For instructions on importing a list of orders for completion using the File > Import menu choice, see
Importing a List of Orders for Completion.
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Complete Orders Selecting orders for completion

Use “Field Settings” to customize the list of fields for selecting orders:

Click the Field Settings button to change the fields that appear in the “Select Orders By” dropdown
field selection list.

Select Orders By From To
Order Number - | Q i 1
{None) -
- ~
% PTDEMO - Complete Orders Field Settings l&]
[Furchese Ouetumbe— T —
Salesperson 2 3 Order Date
Salesperson 4 sabockide; Order Type
Salesperson 5 Ship-To Location Code
All Salespeople Customer Group Code
Picking Slip Printed Customer Accourt Set ‘ Field Setti Load
Deliver By Date Salesperson 1 [ L 0% ] [ —
Ship-Via Code = Expected Ship Date L
Default Location Code On Hald Customer Mum... | Bil - To Mame
Tax Group ACH
Entered By Approved
Note Courier
Optional - Order Date Customer Credit Waming
Prefered Customer Mazdmum Order Amourt
Temporary Customer L5 UPS Zone
ser
Warmarty &

e The list of fields on the right are the fields that will appear in the Select Orders By dropdown.

e To add a field to the dropdown list, select it in the list on the left, and click the Include button.

Note regarding order dates:

e If you choose a range of Order Dates, the default “To” date is set by a screen accessed through
the Complete Orders > File > Settings menu choice:

# PTDEMO - Complete Orders Settings ==
Mumber of Months Prior to Session Date to Complete Orders Ijl

You can override the default in the Range fields.

Choose additional criteria if necessary:

If you want to select orders from a field that is NOT available on the Field Settings form, use
Additional Criteria.

Q Set Criteria - Orders

Field Temitony ‘ | -
Criteria =AK :

Or

=
4 » .
[Show Firter][ Clear.. ” Edit Ir ave
——-—l/ [ Field Settings... ] [ Load ]

¢ Click the Additional Criteria button to further restrict the orders retrieved for completion.

e Select a field in the dropdown and click the Add button.
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Complete Orders Importing a List of Orders for Completion

¢ Double-click the Criteria field to enter a relationship and value.
e Click OK to save.

Load the list of selected orders and choose which ones to complete:

Additional Citeria... [ Feld Settings... | [, Load ]
Include | [E Order Number Order Date | Order Description Cuomer Num... | Bill-To Name
Yes ORDO0OOD000000001  1/15/2019  Please ship ASAP 200 Mr. Ronald Blach
Yes ORDO0ODOD0000D0Z2  1/15/2019  No backorder please 1210 ACME Plumbing
Yes QORDODDODOO0O0DG3  6/30/2020 No backorder 1105 Bargain Mart - O
Yes ORDO0DDOO0OD00DG4  7/1/2020 1200 Mr. Ronald Blac
Yes ORDO0DDOO0OD0ODGS  7/1/2020 1200 Mr. Ronald Blach
Yes ORDO0DDOO0OD00DGE  2/5/2020 1200 Mr. Ronald Blac
Yes ORDO0DDOODD00DGT  2/5/2020 1210 ACME Plumbing
Yes ORDOOD000000DEE  2/5/2020 1240 The Courtyard
Yes ORDO0DDOODD00DGS  2/5/2020 1500 Custom Comfort
Yes ORDO0DOOODOOOTO  2/5/2020 1200 Mr. Ronald Blac
Yes ORDO0DDOO0DD00071  2/5/2020 1200 Mr. Ronald Blach
4 | [l | 2

[ SelectAl  |[ SelectNone | 110rders sslected.
oo oo ]

e Click the Load button to display the selected list of orders.

o Go back and adjust the ranges or additional criteria if necessary.

Importing a List of Orders for Completion

Important: You must choose options for selecting items or miscellaneous charges before importing
the list of orders for completion. See Choose items/miscellaneous charges.

e Choose File > Import from the Complete Orders menu.

SAMLTD - Complete Orders
File

Customize...
ellaneous Charge Lines -

Import...

Close

e Select the list of orders that you want to process.

-
% Open
Ty
» Computer » Local Disk (C:) » Sage300 » XL61A » Documentation »
i, E 2
Organize »  New folder
THEEA * Mame ’ Date modificd Type Size -
| THE7A
v ENG 11/18/202012:45 ... File folder
vaeen ] BillsOfMaterial.xlsx 1/12/20201:24PM  Microsoft Excel W... 9kB
o ] Customersxsx 11/12/2020 124 PM Wicrosoft Excel W... 10k8
: u%ﬁsn #] Employees.xisx 11/12/2020 1:24 M Wicrosoft Excel 10KkB |
e ] Trems.xlsx 11/12/2020 1:24 M Microsoft Excel 10k8
3] ItemSubstitutes.xlsx 11/12/2020 124 PM  Microsoft Excel 10KkB

UX66A B
- U ] Ordersxlsx 11/18/2020 1:00 PM  Microsoft Bxcel W... 9KB

o The program will import the list and load all relevant orders into the grid — setting all orders to
“Include” — and display a message stating the number of orders that were successfully loaded,
and the number of orders that could not be imported.
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Complete Orders Choosing Orders from the Grid for Processing

e | [B Order Number Order Date | Order Description Customer Mum... | Bill-To Name

Yes ORDO0DOD00000E3  6/30/2020  No backerder 1105 Bargain Mart - O
Yes ORDOO @ Message lsesem| | M. Ronald Blac
Yes CORD Mr. Ronald Blach
Yes ORDv Message New Company

= i Description: 7 Orders imported from 'C:*S5age300'*L61A\Documentation - Eaalilexy __ &
Yes ORD ‘\Orders xlsx’. 15 Orders could not be imported. Please see the Complete ACME Plumbing
Yes ORD Orders User Guide for more details. Mr. Ronald Engli

The program will reject orders that cannot be processed, and will not import them.

All orders that can be completed will be loaded into the grid at the botton of the screen. You can then
confirm which orders you want to complete.

Choosing Orders from the Grid for Processing

e Use the Select All and Select None buttons.

[  SelectAl || SeleciMome |

e Double-click in the Include column to “cherry-pick” from the order selections:

Include | [& Order Number Order Date | Order Description Customer Num... | Bill-To Name

ORDO00000000001  1/15/2019  Please ship ASAP Mr. Ronald Blach

k 1/15/2019 | No backorder please

ORDOOD0ODDODO0E3  6/30/2020 Mo backorder 1105 Bargain Mart - O

No
e Click the Order Number column heading to drill down on the selected order:

[& Order Mumber

ORDOO0000000001
ORDO00000000D002

You can also delete an order by selecting it and pressing the Delete key:

e You can also delete an order from the Order Entry program by selecting the row in the Load list
and pressing the Delete key. When the delete key is pressed you will be prompted to confirm the
deletion of that order.

Click the Process button to complete the included orders:

The program asks you to confirm your choices. Click Yes to continue.

Complete Orders B3

Are you sure you want to complete the selected orders?

Note: There may be data-integrity errors that prevent some completions, in which case an error
message will appear.
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Complete Orders Choosing Orders from the Grid for Processing

Click the Log button to confirm which orders were completed:

7/4/2020 1:13:25 PM Complete Orders started.

7/4/2020 1:13:25 PM

7/4/2020 1:13:25 PM Performed by user: ADMIN

7/4/2020 1:13:25 PM

7/4/2020 1:13:25 PM Complete all Item and Miscellaneous Charge Lines
7/4/2020 1:13:25 PM Order Range

7/4/2020 1:13:25 PM Order Number From [] To [ZZZZZZ7277ZZ7Z7Z27272727Z722227]
7/4/2020 1:13:25 PM

7/4/2020 1:13:25 PM Completing Order Number ORD000000000002...
7/4/2020 1:13:26 PM Order Number ORD000000000002 marked complete.
7/4/2020 1:13:26 PM

7/4/2020 1:13:26 PM Complete Orders complete.

7/4/2020 1:13:26 PM

The Log lists:

e The user, the type of lines selected, and the full range settings.

e Each order that was marked complete.
Before and After view of an order grid

To illustrate the effects of running the program, here are before and after views of an order grid from
sample data. Before, the line item is not complete and the quantity outstanding is 50:

D ption No backorder please Reference Ref 0501-2
Lin... Type 9, kem No./ Misc. Charge 9, Kit/BOM Description 9, Price List 9, Location Cty. Ordered  Deliver By a
[ dlfem [A13100 __-EI 1/15/2013 |
2 lem AZ(KINGS-5000)B Kings 5000 Seri... USA 2 1/15/2019
3 tem AZ(IMAGE-1500)G Image 1500 Ser... USA 3 2 1/15/2019

< 1 ] +

After, the line item is complete, with quantity ordered and quantity committed values set to 0. Other
quantities are unaffected:

Description No backorder please Reference Ref 09012
Lin... Type @, tem No./ Misc. Charge 9, Kit/BOM  Description 9, Price List 9, Location Gty. Ordered  Deliver By -
-__——I
2 ltem AZ(KINGS-5000)B Kings 5000 Seri...  USA 0 1/15/2019
3 lem A2(IMAGE-15000G Image 1500 Ser... USA 3 0 1/15/2019
4 I 3
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Complete Orders File Formats for Imported Order and Item Lists

File Formats for Imported Order and ltem Lists

Complete Orders lets you complete groups of orders using an imported order list and an imported list of
item numbers.

Import files — orders and item lists — are Excel files.

You can find examples of import lists in directory “...\Sage300\XL61A\Documentation”.

Order List

Instead of specifying a range of orders and clicking the Load button, you can directly import a list of
orders.

The Excel Spreadsheet order list is a single column with “ORDNUMBER” as the column heading in the
first row.

A
1 ORDMUMEBER
2 ORDOOCOCOOOOOOTL
o All other columns are ignored. This means that you can add item descriptions and notes to your
spreadsheet without affecting the file import.

Item Lists
You can import item lists to further select orders for completion.

The Excel Spreadsheet item list is a single column with “ITEMNQO” as the column heading in the first row.

A
1 ITEMNO
2 |A11030
3 |A11050

Notes:
e |tem numbers can be formatted or unformatted.

o All other columns are ignored. This means that you can add item descriptions and notes to your
spreadsheet without affecting the file import.
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