Complete Purchase Orders Running Complete Purchase Orders

Complete Purchase Orders

Businesses frequently have incomplete purchase orders because items on order are out-of-stock or
discontinued and will never be received from the vendor. As a result, POs remain open and item
guantities on back order are unreliable.

Complete Purchase Orders simplifies the job of completing purchase orders by finding incomplete POs,
zeroing the quantity outstanding for each incomplete line item, and then setting the PO status to
“Complete.”

Complete Purchase Orders lets you:

e Select incomplete purchase orders based on items on order.

o You can complete all lines within a range of orders, complete a specific line item for orders,
or complete all items specified by a list that you import from an Excel spreadsheet file or
enter on the Complete Purchase Orders form.

e Choose from Active, Blanket, Standing and Future purchase orders.

o Carefully consider the business case for completing different types of purchase orders,
especially Blanket purchase orders.

Important: The Complete Purchase Orders program “remembers” the previous setting for the
drop-down that controls purchase order type. If you are completing order types other than Active,
you may wish to re-select Active before leaving the Complete Purchase Orders form.

e Select ranges of incomplete purchase orders, then load the POs to further “cherry-pick” ones for
completion— or import a list of the purchase orders that you need to complete.

e Check PO details while finalizing the completion list.
e Press a Process button to complete the operation for all selected POs in one step.
e Optionally delete completed purchase orders.

e View a log of all changes after processing.

Running Complete Purchase Orders

The Complete Purchase Orders icon appears under TaiRox Productivity Tools > Purchase Order
Tools on the Sage 300 desktop and can be copied to other menu locations.
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Complete Purchase Orders Selecting Purchase Orders for completion

The Complete Purchase Orders screen (below) lets you select which POs you wish to complete by
specifying items, PO type, and various ranges of purchase orders.

PTDEMO - Complete Purchase Orders

File  Help

Complete Purchase Orders

Complete all tem Lines -

Purchase Order Type Active -

Purchase Order Range

Select Purchase Orders By From Ta
(Mone) -

(Mone) -

(None) -

(None) -

(None) -

(None) -

(None) -

[ Addtional Criteria... Field Settings... | | Load

Include | [B Purchase Order Number | Purchase Order Date Description Vendor

< | mn F
Select Al Select None

Selecting Purchase Orders for completion

Choose items:

Complete Purchase Orders
Complete all tem Lines -
Complete all kem Lines |

Complete a Specific kem Line
Complete a List of kems

Complete Purchase Orders displays the choice from the last time that you used the program —
including the specific line item number or the item list that you specified previously.
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Complete Purchase Orders Selecting Purchase Orders for completion

Complete all Item Lines

e Choose this option to complete all items in the range of purchase orders you specify. You can
exclude POs from the range after you click the Load button.

Complete a Specific Item Line

e This choice lets you complete lines for a specific item in all purchase orders in the range you
specify. You can exclude POs from the range after you click the Load button.

Complete a List of Items

e This choice lets you create or import a list of items that you want to complete.

e Click the Drill Down icon on the right side of the dropdown field to create/import/edit the item list.

The program displays a popup form that lets you add items to the list or import a list of items from
a spreadsheet.

Complete Purchase Crders
Complete a List of tems - [ -’
Purch: ‘

%2 PTDEMO - Complete Purchase Orders

Q, ttem Number ltem Description

Purch( | ENRTIEY] Fluorescent Desk Lamp

eon

To import a list:

o Click the Import button at the bottom of the popup form and select the spreadsheet containing
the item list.

— The imported list will replace the current list of items.

o Use the Insert key to add more items to the list.
o Use the Delete key to remove items from the imported list.

Note: The Excel Spreadsheet item list is a single column with “ITEMNQO” as the column heading
in the first row.
A
1 ITEMNO
2 |A11030
3 |A11050

o Item numbers can be formatted or unformatted.
o All other columns are ignored. This means that you can add item descriptions and notes to
your spreadsheet without affecting the file import.

To insert items:

o Use the Insert key to add more items to the list.
o Use the Delete key to remove items.
o The list will be remembered from the previous time you used it to load POs for completion.

Choose purchase order type:

Complete Purchase Orders

Complete a Specific tem Line -
Active -]
Active:
frem Number Standing I:
Future
Purchase Order Range Blarket ‘
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Complete Purchase Orders Selecting Purchase Orders for completion

Important: Check the purchase order type as part of the selection process.

e The Complete Purchase Orders program “remembers” the previous setting for the drop-down that

controls purchase order type. If you are completing order types other than Active, you may wish
to re-select Active before leaving the Complete Purchase Orders form.

Choose ranges of purchase orders:

Purchase Order Range
Select Purchase Orders By From To

Purchase Crder Number - | [

{Mone) |L]
I'Nnnei
Purchase Order Date:

Vendor

Tems Code

Currency

Expected Amival Date

Bill-To Location

Ship-Ta Location

(MarEY -

e You can specify ranges of purchase orders to restrict POs by up to seven fields, such as PO
date, number, vendor, terms, currency, arrival date, locations, or optional PO fields (if added).

e You can add or remove fields from the dropdown list using the Field Settings button.

For instructions on importing a list of purchase orders for completion using the File > Import menu
choice, see Importing a List of Purchase Orders for Completion.

Use the “Field Settings” button to customize the list of fields for selecting POs:
Click Field Settings to change fields that appear in the “Select Purchase Orders By” dropdown list.

Select Purchase Orders By

From To
Purchase Order Number - | |Q [prrzzzzzzEzEzzIIZEZEZ |
S

& PTDEMO - Complete Purchase Orders Field Settings o]
[ShpVa ]
Tems Code Furchase Order Date
Bill-To Location < Exclude Cumency Dawn
Purchase Order Type Ship-To Location
Completed
On Hold
TGen

ere

‘ Field Settings... | | Load
Arival Date Description

e The list of fields on the right are the fields that will appear in the Select Purchase Orders By
dropdown.

e To add a field to the dropdown list, select it in the list on the left, and click the Include button.
Note regarding PO dates:

e If you choose a range of Purchase Order Dates, the default “To” date is set by a screen accessed
through the Complete Purchase Orders > File > Settings menu choice:

% TaiRox Software Inc. - TaiRox Complete Purchase Orders Settings @
Mumber of Months Prior to Session Date to Complete Purchase Orders

You can override the default in the Range fields.
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Complete Purchase Orders

Importing a List of Purchase Orders for Completion

Choose additional criteria if necessary:

Complete Purchase Orders
Complete a Specific tem Line

Purchase Order Type Active -
tem N ) Set Criteria - Purchase Orders = =]
Purcl  Column Lines Complete -
Seled
Field Lines Complete [ | - —~
Pl Citeia =0 ZI"‘
(Nor{ Or
(Nory
(Nory
(Nony 5 LIL‘
(N
o e | -
(Nor|
— T

Click the Additional Criteria button to further restrict the POs retrieved for completion.

Select a field in the dropdown and click the Add button.

Double-click the Criteria field to enter a relationship and value.

Click OK to save.

Load the list of selected POs and choose which ones to complete:

[ Addiional Citeria... | | Field Settings.. |, [ Load |
Include | [B Purchase Order Number | Purchase Order Date Description
Yes PCDOD0D000 1/8/2019 1450
Yes PCOODOOD0D2 1/8/2019 1500
Yes PCOODOOD0D3 1/8/2019 2300 |=
Yes POOODDO0DO04 1/8/2019 6010
Yes PCOODOOD0DS 1/8/2019 7100
Yes PCO0ODOOD0DG 1/8/2019 7936 —
Yes PCOODOODODT 1/8/2019 4540
Yes PCO0DOOD00E 1/8/2019 4540
Yes PCOODODDODS 1/8/2019 4540
Yes POOODOODO10 1/8/2019 4540
Yes PODODO00011 3/4/2019 Tao refill inventory 1200
Yes PCOODOODO12 11/11/2019 1450 _
) Sw |
[ SelectAl | [ SelectNone | 24 Purchase Orders selected.

e Click the Load button to display the selected list of POs.

o

Go back and adjust the ranges or additional criteria if necessary.

Importing a List of Purchase Orders for Completion

Important: You must choose options for selecting items before importing the list of purchase orders
for completion. See Choose items.

e Choose File > Import from the Complete Purchase Orders menu.
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Complete Purchase Orders Choosing Purchase Orders from the Grid for Processing

SAMLTD - Complete Purchase Orders

Customize...

Impert.. Active -

Close

e Select the list of purchase orders that you want to process.
% open =l

—~r—
(I [ 1 v Computer » Local Disk (3} » Sage300 » XL6LA + Documen tation » ~ [ ¢ ||| Search Documentation ol

Organize »  New folder

THEEA * Mame ’ Date modificd Type Size -

| XA
ENG 11/18/202012:45 ... File folder

UPTIA ! ) )

voson ] BillsOfMaterial xlsx /122020 124 PM  Microsoft Becel W.. oke

vaern ] Customersalsx 11122020124 PM Microsoft Bxc 10kB
e 2] Employeesals 11/12/20201:24 PM Microsoft Bxc 10KB
. B Tremsdsc 1/12/2020 124 PM  Microsoft Exc 10KB

uT73C

. o ] lremSubstitutes.xisx 117122020 1:24 PM Microsoft Excel W.. 10KB
. — ] Ordersadsx 11/18/2020 100 PM  Microsoft Excel W. 9KB

e The program will import the list and load all relevant purchase orders into the grid — setting all
POs to “Include” — and display a message stating the number of purchase orders that were
successfully loaded, and the number of POs that could not be imported.

Include | [B Purchase Order Number | Purchase Order Date Description

Yes PODODOOD011 3/4/2015 To refill inventory 1200
Yes FO 1200
Yes PO ) Message ﬁ 7100
Yes FO 1540
Yes PO T 6010
Yes PO Description: 10 Purchase Orders imported from 'C:\Sage 300" XLE1A - 7100
Yes PO “Documentation\PurchaseOrders xdsx’. 2936

The program will reject purchase orders that cannot be processed, and will not import them.

All POs that can be completed will be loaded into the grid at the botton of the screen. You can then
confirm which ones you want to complete.

Choosing Purchase Orders from the Grid for Processing

e Use the Select All and Select None buttons.

[ SelectAl || SelectNome |

e Double-click in the Include column to “cherry-pick” from the PO selections:

gl LR0000006 1/8/2019 . |793 |
Yes POO0O0000007 1/8/2019 4540

e Click the Purchase Order Number column heading to drill down on the selected PO:

[H Purchase li:ilrdfi‘Number

POD0000000]

You can also delete a PO by selecting it and pressing the Delete key:

e You can also delete a purchase order from the Purchase Orders program by selecting the row in
the Load list and pressing the Delete key. When the delete key is pressed you will be prompted
to confirm the deletion of that purchase order.

Click the Process button to complete the included POs:

The program asks you to confirm your choices. Click Yes to continue.
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Complete Purchase Orders Choosing Purchase Orders from the Grid for Processing

Complete Purchase Orders

Are you sure you want to complete the selected purchase orders?

Note: There may be data-integrity errors that prevent some completions, in which case an error
message will appear.

Click the Log button to confirm which POs were completed:

6/25/2020
6/25/2020
6/25/2020
6/25/2020
6/25/2020
6/25/2020
6/25/2020
6/25/2020
6/25/2020
6/25/2020
6/25/2020
6/25/2020
6/25/2020
6/25/2020
6/25/2020

The Log lists:

10
10

:20:
:20:
10:
10:
10:
10:
10:
10:
10:
10:
10:
10:
10:
10:
10:

08
08

AM
AM
AM
AM
AM
AM
AM
AM
AM
AM
AM
AM
AM
AM
AM

Complete Purchase Orders started.
Performed by user: ADMIN

Complete all Item Lines
Purchase Order Type [Active]

Purchase Order Range
Purchase Order Number From [] To [ZZZZZZZZZZ7Z72727272222Z2727]

Processing Purchase Order Number PO000009972...
Purchase Order Number PO000009972 marked complete.

Complete Purchase Orders complete.

e The user, the type of POs selected, and the full range settings.

e Each PO that was marked complete.

TaiRox Productivity Tools for Sage 300

© 2009-2024 TaiRox Software Inc. All rights reserved.



Complete Purchase Orders Effects of Running Complete Purchase Orders

Effects of Running Complete Purchase Orders

To illustrate the effects of running the program, here are before and after views of a purchase order from
sample data.

Before: the line item is not complete and the quantity outstanding is 75.

Lin.. Completed &, kem Number  tem Description %, Location [ Drop-Ship Quantity Ordered ~ Quartity Outstanding &, Unit of Meas =
[ 1[N0 [A1-3200 50W/12V Halogen Bulb __mm_
2 No A1-320/0 50W/12V Halogen Bulb 4

Ll i | L2

After: the line item is complete and the quantity outstanding is 0. Other quantities are unaffected.

Lin.. Completed &, Kem Mumber  tem Description @, Llocaton [ Drop-Ship Quartity Ordered ~ Quartity Outstanding @, Unit of Meas
[ 1lYes [A13200 50W//12V Halogen Bub —__EEI—EI_'
2 Yes A1-320/0 50W/12V Halogen Bulb

File Format for an Imported Item List

Complete Purchase Orders lets you complete item lines based on an item list that's imported from an
Excel spreadsheet.

Import files are Excel files.
You can find examples of import lists in directory “...\Sage300\XL61A\Documentation”.
Item List

The Excel Spreadsheet item list is a single column with “ITEMNO” as the column heading in the first row.

A
1 ITEMNO
2 Al1030
3 Al1050

Notes:
e |tem numbers can be formatted or unformatted.
e All other columns are ignored. This means that you can add item descriptions and notes to your
spreadsheet without affecting the file import.

Purchase Order List

The Excel Spreadsheet PO list is a single column with “PONUMBER” as the column heading in the first
row.
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Complete Purchase Orders File Format for an Imported Item List

A
1 PONUMBER
2 |POOOOCOOO0LL
3 PO00OCO001S

e All other columns are ignored. This means that you can add descriptions and notes to your
spreadsheet without affecting the file import.
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